We want to make sure
you’re protected.

Using an out of date browser puts your personal and network information at risk of falling into the wrong hands. Updated browsers on your computer or tablet will help us keep you protected.

Frequently asked questions.

Why did I receive a message about a software update for my browser?

We detected that you are using an outdated browser that does not meet current industry security standards for protecting web access to consumer payment, network and personal information. You must update your outdated browser by January 2018 to continue to access your account information. This is a change adopted by websites, financial institutions, and the wireless industry as a whole to increase security during the online experience.

How do I know if I am impacted?

Customers on non-mobile devices like laptops or PCs not on the most current Internet web browser version are impacted. Outdated web browsers will display a warning message at the top of your screen when visiting Verizon websites.

Even if your smartphone or devices are not listed above, it is highly recommended that you perform a software update to the most current version to optimize device performance, apply the latest security patches, and resolve known issues.

Smartphones with the following operating systems are also affected:

  • Android OS versions 4.x and older
  • Apple iOS versions 4.0 and older
What action should I take?

You should update to the newest version of your browser. However, if you are using Windows Explorer versions 9.x or 10.x, you may manually configure your browser to be TLS 1.2 compliant by following the steps listed on the section titled “Enabling TLS 1.2 on Windows Explorer versions 9.x and 10.x).

Depending on the browser you use, instructions for upgrading it can be found in one of the following links:

For information on how to update other browsers, please go to that browser’s website.

Enabling TLS 1.2 on Windows Explorer versions 9.x and 10.x

If you are using Windows Explorer versions 9.x or 10.x, following these simple steps will allow you to enable the TLS 1.2 security protocol on your desktop/tablet browser, without a need to upgrade the browser to a newer version

  1. Start a new Internet Explorer browser session
  2. On the upper right hand corner of the browser, click on the gear wheel
  3. Select Internet options
  4. Click on the [Advanced] tab
  5. Scroll down to the end of the list and locate the tag "Use TLS 1.2-ON"
  6. If unselected (no check mark present), click on it to enable it and press [Apply] to post you changes*
  7. Click [OK] to close the dialog box

* You may have to restart your browser for these changes to take effect

What happens if I don’t take any action by January 2018

You will not be able to access any functionality in our web site or perform certain financial transactions that require the new security standards.

Certain 3rd party websites (such as PayPal, banking or payment processing) may not function correctly or their access may be restricted or denied altogether. Due to the unpredictable experience with these websites, it is required that you update your browser to the latest version.

Note: Verizon does not manage or support 3rd party websites – please contact the website’s support.